CVE-2025-64775

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
References
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*
cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*

History

18 Oct 2026, 20:10

Type Values Removed Values Added
Summary
  • (es) Vulnerabilidad de denegación de servicio en Apache Struts, la fuga de archivos en el procesamiento de solicitudes multipart causa el agotamiento del disco. Este problema afecta a Apache Struts: desde 2.0.0 hasta 6.7.0, desde 7.0.0 hasta 7.0.3. Se recomienda a los usuarios actualizar a la versión 6.8.0 o 7.1.1, que soluciona el problema.

Information

Published : 2025-12-01 16:15

Updated : 2026-10-18 20:10


NVD link : CVE-2025-64775

Mitre link : CVE-2025-64775

CVE.ORG link : CVE-2025-64775


JSON object : View

Products Affected

apache

  • struts
CWE
CWE-459

Incomplete Cleanup