CVE-2025-62164

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*
cpe:2.3:a:vllm:vllm:0.11.1:rc0:*:*:*:*:*:*
cpe:2.3:a:vllm:vllm:0.11.1:rc1:*:*:*:*:*:*

History

19 Oct 2026, 13:10

Type Values Removed Values Added
Summary
  • (es) vLLM es un motor de inferencia y servicio para modelos de lenguaje grandes (LLM). Desde las versiones 0.10.2 hasta la 0.11.1, existe una vulnerabilidad de corrupción de memoria que podría conducir a un fallo (denegación de servicio) y potencialmente a ejecución remota de código (RCE) en el endpoint de la API de Completions. Al procesar incrustaciones de prompt proporcionadas por el usuario, el endpoint carga tensores serializados utilizando torch.load() sin validación suficiente. Debido a un cambio introducido en PyTorch 2.8.0, las comprobaciones de integridad de tensores dispersos están deshabilitadas por defecto. Como resultado, los tensores creados maliciosamente pueden eludir las comprobaciones de límites internas y desencadenar una escritura de memoria fuera de límites durante la llamada a to_dense(). Esta corrupción de memoria puede provocar el fallo de vLLM y potencialmente conducir a la ejecución de código en el servidor que aloja vLLM. Este problema ha sido parcheado en la versión 0.11.1.

Information

Published : 2025-11-21 02:15

Updated : 2026-10-19 13:10


NVD link : CVE-2025-62164

Mitre link : CVE-2025-62164

CVE.ORG link : CVE-2025-62164


JSON object : View

Products Affected

vllm

  • vllm
CWE
CWE-20

Improper Input Validation

CWE-123

Write-what-where Condition

CWE-502

Deserialization of Untrusted Data

CWE-787

Out-of-bounds Write