CVE-2025-58098

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
References
Link Resource
https://httpd.apache.org/security/vulnerabilities_24.html Mailing List Vendor Advisory
http://www.openwall.com/lists/oss-security/2025/12/04/5 Mailing List Third Party Advisory
Configurations

Configuration 1 (hide)

cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

History

25 Sep 2026, 23:10

Type Values Removed Values Added
Summary
  • (es) Servidor HTTP Apache 2.4.65 y anteriores con Server Side Includes (SSI) habilitado y mod_cgid (pero no mod_cgi) pasa la cadena de consulta con escape de shell a las directivas #exec cmd='...'. Este problema afecta al Servidor HTTP Apache anterior a 2.4.66. Se recomienda a los usuarios actualizar a la versión 2.4.66, que corrige el problema.

Information

Published : 2025-12-05 14:15

Updated : 2026-09-25 23:10


NVD link : CVE-2025-58098

Mitre link : CVE-2025-58098

CVE.ORG link : CVE-2025-58098


JSON object : View

Products Affected

apache

  • http_server
CWE
CWE-201

Insertion of Sensitive Information Into Sent Data