CVE-2025-58054

Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:*
cpe:2.3:a:discourse:discourse:*:*:*:*:beta:*:*:*
cpe:2.3:a:discourse:discourse:3.6.0:beta1:*:*:beta:*:*:*

History

19 Oct 2026, 17:10

Type Values Removed Values Added
Summary
  • (es) Discourse es una plataforma de discusión comunitaria de código abierto. Las versiones 3.5.0 e inferiores son vulnerables a ataques XSS a través del análisis y la representación de títulos de canales de chat y títulos de hilos de chat mediante la funcionalidad de citar mensajes al usar el editor de texto enriquecido. Este problema está solucionado en la versión 3.5.1.

Information

Published : 2025-10-01 19:15

Updated : 2026-10-19 17:10


NVD link : CVE-2025-58054

Mitre link : CVE-2025-58054

CVE.ORG link : CVE-2025-58054


JSON object : View

Products Affected

discourse

  • discourse
CWE
CWE-80

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)