CVE-2025-34523

A heap-based buffer overflow vulnerability exists in the network-facing input handling routines of Arcserve Unified Data Protection (UDP). This flaw is reachable without authentication and results from improper bounds checking when processing attacker-controlled input. By sending specially crafted data, a remote attacker can corrupt heap memory, potentially causing a denial of service or enabling arbitrary code execution depending on the memory layout and exploitation techniques used. This vulnerability is similar in nature to CVE-2025-34522 but affects a separate code path or component. No user interaction is required, and exploitation occurs in the context of the vulnerable process. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:-:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:update_1:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:update_2:*:*:*:*:*:*

History

26 Sep 2026, 00:10

Type Values Removed Values Added
Summary
  • (es) Una vulnerabilidad de desbordamiento de búfer basado en heap-based existe en las rutinas de manejo de entrada orientadas a la red de Arcserve Unified Data Protection (UDP). Este fallo es alcanzable sin autenticación y resulta de una comprobación de límites inadecuada al procesar entrada controlada por el atacante. Al enviar datos especialmente manipulados, un atacante remoto puede corromper la memoria del heap, potencialmente causando una denegación de servicio o permitiendo la ejecución de código arbitrario dependiendo de la disposición de la memoria y las técnicas de explotación utilizadas. Esta vulnerabilidad es similar en naturaleza a CVE-2025-34522 pero afecta a una ruta de código o componente separado. No se requiere interacción del usuario, y la explotación ocurre en el contexto del proceso vulnerable. Esta vulnerabilidad afecta a todas las versiones de UDP anteriores a la 10.2. UDP 10.2 incluye los parches necesarios y no requiere ninguna acción. Las versiones 8.0 a 10.1 son compatibles y requieren la aplicación del parche o la actualización a la 10.2. Las versiones 7.x y anteriores no son compatibles o están fuera de mantenimiento y deben actualizarse a la 10.2 para remediar el problema.

Information

Published : 2025-08-27 22:15

Updated : 2026-09-26 00:10


NVD link : CVE-2025-34523

Mitre link : CVE-2025-34523

CVE.ORG link : CVE-2025-34523


JSON object : View

Products Affected

arcserve

  • udp
CWE
CWE-122

Heap-based Buffer Overflow