CVE-2025-34522

A heap-based buffer overflow vulnerability exists in the input parsing logic of Arcserve Unified Data Protection (UDP). This flaw can be triggered without authentication by sending specially crafted input to the target system. Improper bounds checking allows an attacker to overwrite heap memory, potentially leading to application crashes or remote code execution. Exploitation occurs in the context of the affected process and does not require user interaction. The vulnerability poses a high risk due to its pre-authentication nature and potential for full compromise. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:-:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:update_1:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:update_2:*:*:*:*:*:*

History

26 Sep 2026, 00:10

Type Values Removed Values Added
Summary
  • (es) Una vulnerabilidad de desbordamiento de búfer basado en heap-based existe en la lógica de análisis de entrada de Arcserve Unified Data Protection (UDP). Este fallo puede ser activado sin autenticación enviando una entrada especialmente diseñada al sistema objetivo. La comprobación de límites incorrecta permite a un atacante sobrescribir la memoria heap, lo que podría llevar a fallos de la aplicación o a la ejecución remota de código. La explotación ocurre en el contexto del proceso afectado y no requiere interacción del usuario. La vulnerabilidad plantea un alto riesgo debido a su naturaleza de pre-autenticación y su potencial de compromiso total. Esta vulnerabilidad afecta a todas las versiones de UDP anteriores a la 10.2. UDP 10.2 incluye los parches necesarios y no requiere ninguna acción. Las versiones 8.0 a 10.1 son compatibles y requieren la aplicación de parches o la actualización a la 10.2. Las versiones 7.x y anteriores no son compatibles o están fuera de mantenimiento y deben actualizarse a la 10.2 para remediar el problema.

Information

Published : 2025-08-27 22:15

Updated : 2026-10-23 22:10


NVD link : CVE-2025-34522

Mitre link : CVE-2025-34522

CVE.ORG link : CVE-2025-34522


JSON object : View

Products Affected

arcserve

  • udp
CWE
CWE-122

Heap-based Buffer Overflow