CVE-2025-34521

A reflected cross-site scripting (XSS) vulnerability exists in the web interface of the Arcserve Unified Data Protection (UDP), where unsanitized user input is improperly reflected in HTTP responses. This flaw allows remote attackers with low privileges to craft malicious links that, when visited by another user, execute arbitrary JavaScript in the victim’s browser. Successful exploitation may lead to session hijacking, credential theft, or other client-side impacts. The vulnerability requires user interaction and occurs within a shared browser context. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.
Configurations

Configuration 1 (hide)

OR cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:*:*:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:-:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:update_1:*:*:*:*:*:*
cpe:2.3:a:arcserve:udp:7.0:update_2:*:*:*:*:*:*

History

26 Sep 2026, 00:10

Type Values Removed Values Added
Summary
  • (es) Una vulnerabilidad de cross-site scripting (XSS) reflejado existe en la interfaz web de Arcserve Unified Data Protection (UDP), donde la entrada de usuario no saneada se refleja incorrectamente en las respuestas HTTP. Esta falla permite a atacantes remotos con bajos privilegios crear enlaces maliciosos que, al ser visitados por otro usuario, ejecutan JavaScript arbitrario en el navegador de la víctima. La explotación exitosa puede llevar a secuestro de sesión, robo de credenciales u otros impactos del lado del cliente. La vulnerabilidad requiere interacción del usuario y ocurre dentro de un contexto de navegador compartido. Esta vulnerabilidad afecta a todas las versiones de UDP anteriores a la 10.2. UDP 10.2 incluye los parches necesarios y no requiere ninguna acción. Las versiones 8.0 a 10.1 son compatibles y requieren la aplicación de parches o la actualización a la 10.2. Las versiones 7.x y anteriores no son compatibles o están fuera de mantenimiento y deben actualizarse a la 10.2 para remediar el problema.

Information

Published : 2025-08-27 22:15

Updated : 2026-09-26 00:10


NVD link : CVE-2025-34521

Mitre link : CVE-2025-34521

CVE.ORG link : CVE-2025-34521


JSON object : View

Products Affected

arcserve

  • udp
CWE
CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')