CVE-2025-15444

Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277  https://www.cve.org/CVERecord?id=CVE-2025-69277 . The libsodium vulnerability states: In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group. 0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.
Configurations

Configuration 1 (hide)

cpe:2.3:a:iamb:crypt\:\:sodium\:\:xs:*:*:*:*:*:perl:*:*

History

05 Oct 2026, 14:10

Type Values Removed Values Added
Summary (es) Las versiones del módulo Crypt::Sodium::XS anteriores a 0.000042, para Perl, incluyen una versión vulnerable de libsodium. libsodium <= 1.0.20 o una versión de libsodium lanzada antes del 30 de diciembre de 2025 contiene una vulnerabilidad documentada como CVE-2025-69277 https://www.cve.org/CVERecord?id=CVE-2025-69277. La vulnerabilidad de libsodium establece: En casos de uso atípicos que involucran cierta criptografía personalizada o datos no confiables para crypto_core_ed25519_is_valid_point, maneja incorrectamente las comprobaciones de si un punto de curva elíptica es válido porque a veces permite puntos que no están en el grupo criptográfico principal. 0.000042 incluye una versión de libsodium actualizada a 1.0.20-stable, lanzada el 3 de enero de 2026, que incluye una corrección para la vulnerabilidad. (es) Las versiones del módulo Crypt::Sodium::XS anteriores a 0.000042, para Perl, incluyen una versión vulnerable de libsodium. libsodium menor o igual a 1.0.20 o una versión de libsodium lanzada antes del 30 de diciembre de 2025 contiene una vulnerabilidad documentada como CVE-2025-69277 https://www.cve.org/CVERecord?id=CVE-2025-69277. La vulnerabilidad de libsodium establece: En casos de uso atípicos que involucran cierta criptografía personalizada o datos no confiables para crypto_core_ed25519_is_valid_point, maneja incorrectamente las comprobaciones de si un punto de curva elíptica es válido porque a veces permite puntos que no están en el grupo criptográfico principal. 0.000042 incluye una versión de libsodium actualizada a 1.0.20-stable, lanzada el 3 de enero de 2026, que incluye una corrección para la vulnerabilidad.

30 Sep 2026, 22:10

Type Values Removed Values Added
Summary
  • (es) Las versiones del módulo Crypt::Sodium::XS anteriores a 0.000042, para Perl, incluyen una versión vulnerable de libsodium. libsodium <= 1.0.20 o una versión de libsodium lanzada antes del 30 de diciembre de 2025 contiene una vulnerabilidad documentada como CVE-2025-69277 https://www.cve.org/CVERecord?id=CVE-2025-69277. La vulnerabilidad de libsodium establece: En casos de uso atípicos que involucran cierta criptografía personalizada o datos no confiables para crypto_core_ed25519_is_valid_point, maneja incorrectamente las comprobaciones de si un punto de curva elíptica es válido porque a veces permite puntos que no están en el grupo criptográfico principal. 0.000042 incluye una versión de libsodium actualizada a 1.0.20-stable, lanzada el 3 de enero de 2026, que incluye una corrección para la vulnerabilidad.

Information

Published : 2026-01-06 01:16

Updated : 2026-10-07 10:10


NVD link : CVE-2025-15444

Mitre link : CVE-2025-15444

CVE.ORG link : CVE-2025-15444


JSON object : View

Products Affected

iamb

  • crypt\
CWE
CWE-347

Improper Verification of Cryptographic Signature