CVE-2025-13146

The The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.0.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The vulnerability was partially patched in version 5.0.4.
Configurations

No configuration.

History

29 Sep 2026, 19:10

Type Values Removed Values Added
Summary
  • (es) El plugin Contact Form 7 - Dynamic Text Extension para WordPress es vulnerable a la ejecución arbitraria de shortcodes en todas las versiones hasta e incluyendo la 5.0.6. Esto se debe a que el software permite a los usuarios ejecutar una acción que no valida correctamente un valor antes de ejecutar do_shortcode. Esto hace posible que atacantes no autenticados ejecuten shortcodes arbitrarios. La vulnerabilidad fue parcialmente parcheada en la versión 5.0.4.

Information

Published : 2026-07-22 12:16

Updated : 2026-09-29 19:10


NVD link : CVE-2025-13146

Mitre link : CVE-2025-13146

CVE.ORG link : CVE-2025-13146


JSON object : View

Products Affected

No product.

CWE
CWE-94

Improper Control of Generation of Code ('Code Injection')